wordpress theme not displaying properly

You just installed a wordpress theme and when you activated it (or even previewed it), it does not show properly. It takes the whole page, there is only html contents, no formatting is applied. This happened to me when I installed my new template. Interesting it worked on my local system but did not work on my public domain.

I troubleshooted this using Firefox Developer Plugin. If you have already installed it, you can right click in the page, in the popup menu go to Web Developer > CSS > View CSS


This will show all your CSS files in the page. In my case I had 403 (Permission denied in front of style.css)

403 Permission Denied

403 Permission Denied

You do not have permission for this request /wp-content/themes/desire/style.css

So I went to the directory and checked the permission. Indeed it was set to 0600 while it should have been 0644. I click on 0600 and changed it to 0644 (I had to do it twice, the first time it did not work), and my theme was displaying properly.

Advertisements
This entry was posted in Troubeleshoot. Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s